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Enseignant & TIC(E)

♣ Concevoir le scénario pédagogique

♣ Dématérialiser la classe présentielle

♣ Médiatiser les aires d’apprentissage

♣ Tutorer les interactions

♣ Évaluer le dispositif prototypé

Gestionnaire de parcours

♣ Designer et piloter l’ENT

♣ Créer les classes virtualisées

♣ Attribuer les rôles d’accès

♣ Prospecter les historiques d’activités

♣ Améliorer les schémas directeurs

Organisation de l’exposé
1 Préacquis et prise en mains de Moodle

2 Médiatisation des aires d’apprentissage

3 Médiation tutorée d’apprentissage

4 Conducteur pédagogique
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Ensemble de situations d’apprentissage

Organisé comme un tout autonome, polyvalent et cohérent, concourant :

– à la démassification de l’éducation,

– au calcul du temps de travail personnel de l’apprenant,

– à l’audit qualité de l’offre de formation académique.

♣ Autonomie : apprenant autonome et ses besoins anticipés

♣ Polyvalence : re-utilisable (grains) et exige peu de prérequis

♣ Cohérence : vis-à-vis des objectifs visés
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Unités d’enseignement (UE) : ChDisc n1 n2 n3 n4

♣ Champ disciplinaire (ChDisc) : (MTH, TCC, INF, EDU, FPU, MTU, etc.)

♣ Niveaux d’études (n1) : L (1) ; M (2) ; D (3) ; Post-Doc/DES (4) ; Non créditée (0)

♣ Semestres (n2) :

L (1-6) ; M (1-4) ; D (1-6) ; Post-Doc/DES (1-9,0) ; Non créditée (1,2)

♣ Domaine (n3n4 = 00 à 99) :

Sciences et technologies (20-29) ; Sciences de l’éducation et de la formation (70-79)

Exemple : MTH2122 - Variétés lisses régulières : mouvements d’objets naturels

Éléments constitutifs (EC) d’UE : n5 ChDisc n1 n2 n3 n4

♣ Numéro d’ordre de l’EC : (n5 = 1-3)

TCC2224 - Production et diffusion de l’information scientifique et technique (IST)

1TCC2224 - Rédaction scientifique électronique (articles, rapports, diaporamas, CV, QCM)

2TCC2224 - Publication en ligne de parutions scientifiques (revues, presses)
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Procédure d’installation

♣ Installer un serveur PHP/MySQL (php5/php7,
apache2, mysql-server, phpmyadmin)

♣ Télécharger le logiciel Moodle depuis le site
https://moodle.org

♣ Héberger le dossier du site (sudo cp -R
chemin-dossier-site chemin-hébergeur)

♣ Rendre www-data propriétaire du dossier du site
(sudo chown -R www-data chemin-site-hébergé)

♣ Créer le dossier de téléchargement du site (sudo
mkdir chemin-dossier-téléchargement)

♣ Rendre www-data propriétaire du dossier (sudo
chown -R www-data chemin-dossier-téléchargement)

♣ Se rendre sur la page d’accueil et suivre les
instructions

Moodle
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Préacquis et prise en mains de Moodle
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♣ Rendre www-data propriétaire du dossier du site
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♣ Rendre www-data propriétaire du dossier (sudo
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♣ Rendre www-data propriétaire du dossier du site
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chown -R www-data chemin-dossier-téléchargement)
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Préacquis et prise en mains de Moodle
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♣ Se rendre sur la page d’accueil et suivre les
instructions

Moodle

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride

https://moodle.org
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♣ Se rendre sur la page d’accueil et suivre les
instructions

Moodle

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride

https://moodle.org
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Médiatisation des aires d’apprentissage

Médiation tutorée d’apprentissage
Conducteur pédagogique

@Appr : Rôle de gestionnaire de la plateforme 16

1re prise en mains de l’interface graphique

♣ Installer la langue de travail

– Administration du site → Langue → Paquetage de langue → Choisir la langue → Installer
les paquetages de langue sélectionnées → Réglages langue → Langue par défaut = fr →
Langues du menu des langues = fr→ Personnalisation de la langue→ Choisir la langue→
Ouvrir le paquetage de langue pour modification → Continuer

– Préférences utilisateur → Langue préférée → Choisir fr → Enregistrer

♣ Choisir l’éditeur de texte : Administration du site → Plugins → Éditeur de texte → Gérer
les éditeurs → Monter TinyMCE en 1re position

♣ Réglage de la page d’accueil : Administration du site → Réglage de la page d’accueil →
Page d’accueil visiteur → Liste des catégories de cours → Zone de recherche → Annonces
→ Page d’accueil de gestion → Liste des catégories de cours → Zone de recherche →
Annonces → Enregistrer les modifications

♣ Installer le thème ergonomique

– Administration du site → Présentation → Sélecteur de thème → Défault → Changer de
thème → Utiliser le thème → Continuer → Accueil du site

– Administration du site → Présentation → Nom du thème choisi → Procéder aux
paramétrages souhaités
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Page d’accueil visiteur → Liste des catégories de cours → Zone de recherche → Annonces
→ Page d’accueil de gestion → Liste des catégories de cours → Zone de recherche →
Annonces → Enregistrer les modifications

♣ Installer le thème ergonomique

– Administration du site → Présentation → Sélecteur de thème → Défault → Changer de
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♣ Réglage de la page d’accueil : Administration du site → Réglage de la page d’accueil →
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Médiatisation des aires d’apprentissage

Médiation tutorée d’apprentissage
Conducteur pédagogique

@Appr : Rôle de gestionnaire de la plateforme 20

2e prise en mains de l’interface graphique

♣ Réglages par défaut des cours : Administration du site → Cours → Réglages par défaut des
cours → Mise en page du cours = Afficher une section par page → Taille maximal des
fichiers déposé = 10M → Enregistrer les modifications

♣ Réglages généraux des notes : Administration du site → Notes → Réglages généraux →
Modules principaux d’exportation des notes = ODS, TXT, XSLX → Nombre maximum de
points = 20 → Nombre de points par défaut = 20 → Enregistrer les modifications

♣ Rendre hypertexte les articles de glossaires

– Administration du site → Plugins → Gestion des filtres → Liens automatiques des activités
= désactivé → Liaison automatique des glossaires = Activé → Notation TEX = Activé →
Enregistrer les modifications

– Administration du site→ Plugins→ Modules d’activité→ Glossaire→ Réglages par défaut
des articles → Activer les liens automatiques = Coché → Enregistrer les modifications

♣ Réglages par défaut des leçons : Administration du site → Plugins → Modules d’activité →
Leçon → Barre de progression = Oui → Afficher le score actuel = Oui → Afficher le menu
= Oui → Permettre la relecture = Oui → Possibilité de refaire une question = Oui →
Nombre maximal de tentatives = 4 → Plusieurs tentatives permises = Oui → Enregistrer
les modifications
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Enregistrer les modifications

– Administration du site→ Plugins→ Modules d’activité→ Glossaire→ Réglages par défaut
des articles → Activer les liens automatiques = Coché → Enregistrer les modifications

♣ Réglages par défaut des leçons : Administration du site → Plugins → Modules d’activité →
Leçon → Barre de progression = Oui → Afficher le score actuel = Oui → Afficher le menu
= Oui → Permettre la relecture = Oui → Possibilité de refaire une question = Oui →
Nombre maximal de tentatives = 4 → Plusieurs tentatives permises = Oui → Enregistrer
les modifications

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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2e prise en mains de l’interface graphique

♣ Réglages par défaut des cours : Administration du site → Cours → Réglages par défaut des
cours → Mise en page du cours = Afficher une section par page → Taille maximal des
fichiers déposé = 10M → Enregistrer les modifications

♣ Réglages généraux des notes : Administration du site → Notes → Réglages généraux →
Modules principaux d’exportation des notes = ODS, TXT, XSLX → Nombre maximum de
points = 20 → Nombre de points par défaut = 20 → Enregistrer les modifications

♣ Rendre hypertexte les articles de glossaires

– Administration du site → Plugins → Gestion des filtres → Liens automatiques des activités
= désactivé → Liaison automatique des glossaires = Activé → Notation TEX = Activé →
Enregistrer les modifications

– Administration du site→ Plugins→ Modules d’activité→ Glossaire→ Réglages par défaut
des articles → Activer les liens automatiques = Coché → Enregistrer les modifications

♣ Réglages par défaut des leçons : Administration du site → Plugins → Modules d’activité →
Leçon → Barre de progression = Oui → Afficher le score actuel = Oui → Afficher le menu
= Oui → Permettre la relecture = Oui → Possibilité de refaire une question = Oui →
Nombre maximal de tentatives = 4 → Plusieurs tentatives permises = Oui → Enregistrer
les modifications

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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3e prise en mains de l’interface graphique

♣ Catégories de cours (typologie des cours offerts : domaines ; parcours diplômants) :
Administration du site → Cours → Gestion des cours et catégories → Ajouter une catégorie
→ Nom → Description → Créer

♣ Création d’un cours (expériences d’apprentissage ; activités scénarisées et médiatisés) :
Accueil → Cliquer sur la catégorie → Ajouter un cours → Nom complet → Nom abrégé →
Résumé → Format → Nombre de sections → Enregistrer

♣ Attribution des rôles (inscrire les enseignants, étudiants, tuteurs et gestionnaires du cours) :
Réglages → Utilisateurs → Méthodes d’inscription → Ouvrir/fermer l’œil devant :
manuelle, anonyme ou auto-inscription

♣ Titrer et introduire les sections : Activer le mode édition → Modifier → Nom de section
→ Résumé → Enregistrer

♣ Insérer des activités (proposer des scénarios d’apprentissage et d’encadrement) : Activer le
mode édition→ Ajouter une activité→ Glossaire, Test, Leçon, Devoir, Feedback, Atelier→
Paramétrer l’activité → Enregistrer et revenir au cours

♣ Insérer des étiquettes (mettre des instructions texte entre des ressources ou des activités) :

Activer le mode édition → Ajouter une ressource → Étiquette → Contenu → Enregistrer

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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3e prise en mains de l’interface graphique

♣ Catégories de cours (typologie des cours offerts : domaines ; parcours diplômants) :
Administration du site → Cours → Gestion des cours et catégories → Ajouter une catégorie
→ Nom → Description → Créer

♣ Création d’un cours (expériences d’apprentissage ; activités scénarisées et médiatisés) :
Accueil → Cliquer sur la catégorie → Ajouter un cours → Nom complet → Nom abrégé →
Résumé → Format → Nombre de sections → Enregistrer

♣ Attribution des rôles (inscrire les enseignants, étudiants, tuteurs et gestionnaires du cours) :
Réglages → Utilisateurs → Méthodes d’inscription → Ouvrir/fermer l’œil devant :
manuelle, anonyme ou auto-inscription

♣ Titrer et introduire les sections : Activer le mode édition → Modifier → Nom de section
→ Résumé → Enregistrer

♣ Insérer des activités (proposer des scénarios d’apprentissage et d’encadrement) : Activer le
mode édition→ Ajouter une activité→ Glossaire, Test, Leçon, Devoir, Feedback, Atelier→
Paramétrer l’activité → Enregistrer et revenir au cours

♣ Insérer des étiquettes (mettre des instructions texte entre des ressources ou des activités) :

Activer le mode édition → Ajouter une ressource → Étiquette → Contenu → Enregistrer

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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3e prise en mains de l’interface graphique

♣ Catégories de cours (typologie des cours offerts : domaines ; parcours diplômants) :
Administration du site → Cours → Gestion des cours et catégories → Ajouter une catégorie
→ Nom → Description → Créer

♣ Création d’un cours (expériences d’apprentissage ; activités scénarisées et médiatisés) :
Accueil → Cliquer sur la catégorie → Ajouter un cours → Nom complet → Nom abrégé →
Résumé → Format → Nombre de sections → Enregistrer

♣ Attribution des rôles (inscrire les enseignants, étudiants, tuteurs et gestionnaires du cours) :
Réglages → Utilisateurs → Méthodes d’inscription → Ouvrir/fermer l’œil devant :
manuelle, anonyme ou auto-inscription

♣ Titrer et introduire les sections : Activer le mode édition → Modifier → Nom de section
→ Résumé → Enregistrer

♣ Insérer des activités (proposer des scénarios d’apprentissage et d’encadrement) : Activer le
mode édition→ Ajouter une activité→ Glossaire, Test, Leçon, Devoir, Feedback, Atelier→
Paramétrer l’activité → Enregistrer et revenir au cours

♣ Insérer des étiquettes (mettre des instructions texte entre des ressources ou des activités) :

Activer le mode édition → Ajouter une ressource → Étiquette → Contenu → Enregistrer

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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3e prise en mains de l’interface graphique

♣ Catégories de cours (typologie des cours offerts : domaines ; parcours diplômants) :
Administration du site → Cours → Gestion des cours et catégories → Ajouter une catégorie
→ Nom → Description → Créer

♣ Création d’un cours (expériences d’apprentissage ; activités scénarisées et médiatisés) :
Accueil → Cliquer sur la catégorie → Ajouter un cours → Nom complet → Nom abrégé →
Résumé → Format → Nombre de sections → Enregistrer

♣ Attribution des rôles (inscrire les enseignants, étudiants, tuteurs et gestionnaires du cours) :
Réglages → Utilisateurs → Méthodes d’inscription → Ouvrir/fermer l’œil devant :
manuelle, anonyme ou auto-inscription

♣ Titrer et introduire les sections : Activer le mode édition → Modifier → Nom de section
→ Résumé → Enregistrer

♣ Insérer des activités (proposer des scénarios d’apprentissage et d’encadrement) : Activer le
mode édition→ Ajouter une activité→ Glossaire, Test, Leçon, Devoir, Feedback, Atelier→
Paramétrer l’activité → Enregistrer et revenir au cours

♣ Insérer des étiquettes (mettre des instructions texte entre des ressources ou des activités) :

Activer le mode édition → Ajouter une ressource → Étiquette → Contenu → Enregistrer

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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3e prise en mains de l’interface graphique

♣ Catégories de cours (typologie des cours offerts : domaines ; parcours diplômants) :
Administration du site → Cours → Gestion des cours et catégories → Ajouter une catégorie
→ Nom → Description → Créer

♣ Création d’un cours (expériences d’apprentissage ; activités scénarisées et médiatisés) :
Accueil → Cliquer sur la catégorie → Ajouter un cours → Nom complet → Nom abrégé →
Résumé → Format → Nombre de sections → Enregistrer

♣ Attribution des rôles (inscrire les enseignants, étudiants, tuteurs et gestionnaires du cours) :
Réglages → Utilisateurs → Méthodes d’inscription → Ouvrir/fermer l’œil devant :
manuelle, anonyme ou auto-inscription

♣ Titrer et introduire les sections : Activer le mode édition → Modifier → Nom de section
→ Résumé → Enregistrer

♣ Insérer des activités (proposer des scénarios d’apprentissage et d’encadrement) : Activer le
mode édition→ Ajouter une activité→ Glossaire, Test, Leçon, Devoir, Feedback, Atelier→
Paramétrer l’activité → Enregistrer et revenir au cours

♣ Insérer des étiquettes (mettre des instructions texte entre des ressources ou des activités) :

Activer le mode édition → Ajouter une ressource → Étiquette → Contenu → Enregistrer

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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3e prise en mains de l’interface graphique

♣ Catégories de cours (typologie des cours offerts : domaines ; parcours diplômants) :
Administration du site → Cours → Gestion des cours et catégories → Ajouter une catégorie
→ Nom → Description → Créer

♣ Création d’un cours (expériences d’apprentissage ; activités scénarisées et médiatisés) :
Accueil → Cliquer sur la catégorie → Ajouter un cours → Nom complet → Nom abrégé →
Résumé → Format → Nombre de sections → Enregistrer

♣ Attribution des rôles (inscrire les enseignants, étudiants, tuteurs et gestionnaires du cours) :
Réglages → Utilisateurs → Méthodes d’inscription → Ouvrir/fermer l’œil devant :
manuelle, anonyme ou auto-inscription

♣ Titrer et introduire les sections : Activer le mode édition → Modifier → Nom de section
→ Résumé → Enregistrer

♣ Insérer des activités (proposer des scénarios d’apprentissage et d’encadrement) : Activer le
mode édition→ Ajouter une activité→ Glossaire, Test, Leçon, Devoir, Feedback, Atelier→
Paramétrer l’activité → Enregistrer et revenir au cours

♣ Insérer des étiquettes (mettre des instructions texte entre des ressources ou des activités) :

Activer le mode édition → Ajouter une ressource → Étiquette → Contenu → Enregistrer
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Chronologie conseillée
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Processus d’activités

Autres activités
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4e prise en mains de l’interface graphique

♣ Installer des plugins (téléchargés sur https://moodle.org) : Administration du site →
Plugins → Installer un plugin (activités, thèmes, formats de cours, blocs, types de
questions, éditeurs) → Installer le paquet à partir du fichier .zip → Continuer → Mettre à
jour la base de données maintenant → Continuer → Enregistrer les modifications

Désinstaller un plugin : Administration du site → Plugins → Vue d’ensemble des plugins
→ Bouton ”Désinstaller” = devant la ligne du plugin → Confirmer→ Continuer → Mettre
à jour la base de données maintenant

♣ Organiser avec Multiblocks les panneaux d’informations dans sa classe en ligne :
Administration du site → Activer l’édition des blocs → Page d’accueil du cours → Ajouter
un bloc→ Multiblocks→ Configurer le bloc Multiblocks→ Titre→ Style de présentation
= Accordion ; Carousel ; Dropdown→ Enregistrer→ Manage Multiblocks contents→ Add
a new sub-block → Sélectionner un bloc → Ajouter → Page d’accueil du cours

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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4e prise en mains de l’interface graphique

♣ Installer des plugins (téléchargés sur https://moodle.org) : Administration du site →
Plugins → Installer un plugin (activités, thèmes, formats de cours, blocs, types de
questions, éditeurs) → Installer le paquet à partir du fichier .zip → Continuer → Mettre à
jour la base de données maintenant → Continuer → Enregistrer les modifications

Désinstaller un plugin : Administration du site → Plugins → Vue d’ensemble des plugins
→ Bouton ”Désinstaller” = devant la ligne du plugin → Confirmer→ Continuer → Mettre
à jour la base de données maintenant

♣ Organiser avec Multiblocks les panneaux d’informations dans sa classe en ligne :
Administration du site → Activer l’édition des blocs → Page d’accueil du cours → Ajouter
un bloc→ Multiblocks→ Configurer le bloc Multiblocks→ Titre→ Style de présentation
= Accordion ; Carousel ; Dropdown→ Enregistrer→ Manage Multiblocks contents→ Add
a new sub-block → Sélectionner un bloc → Ajouter → Page d’accueil du cours

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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@Appr : Activité - Glossaire 35

Concepts clés (mémorisation)

– Réglages → Administration du site → Plugins → Filtres → Gestion des filtres → Activer
les liens automatiques des glossaires

– Administration du site→ Plugins→ Modules d’activité→ Glossaire→ Réglages par défaut
des articles → Activer les liens automatiques = Coché → Enregistrer les modifications

♣ Constitution du glossaire : Activer le mode édition → Ajouter une activité → Glossaire →
Nom → Description → Type de glossaire = global ; principal ; secondaires → Activer les
liens automatiques → Enregistrer et revenir au cours

♣ Alimentation du glossaire : Page d’accueil du cours → Cliquer sur le nom du glossaire →
Ajouter un nouvel article → Concept → Définition → Termes associés → Annexe →
Article lié automatiquement → Enregistrer

Partage d’articles d’un glossaire

♣ Export : Page d’accueil du glossaire → Réglages → Exporter des articles → Exporter les
articles vers un fichier → Enregistrer le fichier → Ok

♣ Import : Page d’accueil du glossaire → Réglages → Importer des articles → Choisir un
fichier → Glossaire actuel → Envoyer

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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Médiatisation des aires d’apprentissage

Médiation tutorée d’apprentissage
Conducteur pédagogique

@Appr : Activité - Glossaire 36

Concepts clés (mémorisation)

– Réglages → Administration du site → Plugins → Filtres → Gestion des filtres → Activer
les liens automatiques des glossaires

– Administration du site→ Plugins→ Modules d’activité→ Glossaire→ Réglages par défaut
des articles → Activer les liens automatiques = Coché → Enregistrer les modifications

♣ Constitution du glossaire : Activer le mode édition → Ajouter une activité → Glossaire →
Nom → Description → Type de glossaire = global ; principal ; secondaires → Activer les
liens automatiques → Enregistrer et revenir au cours

♣ Alimentation du glossaire : Page d’accueil du cours → Cliquer sur le nom du glossaire →
Ajouter un nouvel article → Concept → Définition → Termes associés → Annexe →
Article lié automatiquement → Enregistrer

Partage d’articles d’un glossaire

♣ Export : Page d’accueil du glossaire → Réglages → Exporter des articles → Exporter les
articles vers un fichier → Enregistrer le fichier → Ok

♣ Import : Page d’accueil du glossaire → Réglages → Importer des articles → Choisir un
fichier → Glossaire actuel → Envoyer

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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@Appr : Découverte par l’image exercisée 37

Questionner une suite d’images

♣ Conception avec Image slider : Page d’accueil d’une UE → Activer le mode édition →
Ajouter une activité H5P → Éditeur = Image slider → Titre → Image → Texte alternatif
→ Texte de survol → Ratio de l’affichage = Variable → Ajouter item → Options et textes
→ Enregistrer

♣ Conception avec Flashcards : Page d’accueil d’une UE → Activer le mode édition →
Ajouter une activité H5P → Éditeur = Flashcards → Titre → Consignes → Cartes →
Question → Réponse → Image → Indice → Options et textes → Enregistrer

♣ Conception avec Lightbox : Page d’accueil d’une UE → Activer le mode édition → Ajouter
une ressource → Type = Galerie d’images Lightbox → Nom → Description → Enregistrer
et afficher → Ajouter des images (individuelles ou archivées) → Ajouter un commentaire

♣ Conception avec Livre : Page d’accueil d’une UE → Activer le mode édition → Ajouter une
ressource → Type = Livre → Nom → Description → Format des titres de chapitres =
Aucun ; Nombre ; Puces ; Indentation → Style de navigation = Seulement table des
matières ; Images ; Texte → Enregistrer et afficher → Ajouter des chapitres (ne contenant
que des images) → Nom → Contenu → Enregistrer
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Questionner une suite d’images

♣ Conception avec Image slider : Page d’accueil d’une UE → Activer le mode édition →
Ajouter une activité H5P → Éditeur = Image slider → Titre → Image → Texte alternatif
→ Texte de survol → Ratio de l’affichage = Variable → Ajouter item → Options et textes
→ Enregistrer

♣ Conception avec Flashcards : Page d’accueil d’une UE → Activer le mode édition →
Ajouter une activité H5P → Éditeur = Flashcards → Titre → Consignes → Cartes →
Question → Réponse → Image → Indice → Options et textes → Enregistrer

♣ Conception avec Lightbox : Page d’accueil d’une UE → Activer le mode édition → Ajouter
une ressource → Type = Galerie d’images Lightbox → Nom → Description → Enregistrer
et afficher → Ajouter des images (individuelles ou archivées) → Ajouter un commentaire

♣ Conception avec Livre : Page d’accueil d’une UE → Activer le mode édition → Ajouter une
ressource → Type = Livre → Nom → Description → Format des titres de chapitres =
Aucun ; Nombre ; Puces ; Indentation → Style de navigation = Seulement table des
matières ; Images ; Texte → Enregistrer et afficher → Ajouter des chapitres (ne contenant
que des images) → Nom → Contenu → Enregistrer

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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Questionner une suite d’images

♣ Conception avec Image slider : Page d’accueil d’une UE → Activer le mode édition →
Ajouter une activité H5P → Éditeur = Image slider → Titre → Image → Texte alternatif
→ Texte de survol → Ratio de l’affichage = Variable → Ajouter item → Options et textes
→ Enregistrer

♣ Conception avec Flashcards : Page d’accueil d’une UE → Activer le mode édition →
Ajouter une activité H5P → Éditeur = Flashcards → Titre → Consignes → Cartes →
Question → Réponse → Image → Indice → Options et textes → Enregistrer

♣ Conception avec Lightbox : Page d’accueil d’une UE → Activer le mode édition → Ajouter
une ressource → Type = Galerie d’images Lightbox → Nom → Description → Enregistrer
et afficher → Ajouter des images (individuelles ou archivées) → Ajouter un commentaire

♣ Conception avec Livre : Page d’accueil d’une UE → Activer le mode édition → Ajouter une
ressource → Type = Livre → Nom → Description → Format des titres de chapitres =
Aucun ; Nombre ; Puces ; Indentation → Style de navigation = Seulement table des
matières ; Images ; Texte → Enregistrer et afficher → Ajouter des chapitres (ne contenant
que des images) → Nom → Contenu → Enregistrer

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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Questionner une suite d’images

♣ Conception avec Image slider : Page d’accueil d’une UE → Activer le mode édition →
Ajouter une activité H5P → Éditeur = Image slider → Titre → Image → Texte alternatif
→ Texte de survol → Ratio de l’affichage = Variable → Ajouter item → Options et textes
→ Enregistrer

♣ Conception avec Flashcards : Page d’accueil d’une UE → Activer le mode édition →
Ajouter une activité H5P → Éditeur = Flashcards → Titre → Consignes → Cartes →
Question → Réponse → Image → Indice → Options et textes → Enregistrer

♣ Conception avec Lightbox : Page d’accueil d’une UE → Activer le mode édition → Ajouter
une ressource → Type = Galerie d’images Lightbox → Nom → Description → Enregistrer
et afficher → Ajouter des images (individuelles ou archivées) → Ajouter un commentaire

♣ Conception avec Livre : Page d’accueil d’une UE → Activer le mode édition → Ajouter une
ressource → Type = Livre → Nom → Description → Format des titres de chapitres =
Aucun ; Nombre ; Puces ; Indentation → Style de navigation = Seulement table des
matières ; Images ; Texte → Enregistrer et afficher → Ajouter des chapitres (ne contenant
que des images) → Nom → Contenu → Enregistrer

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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@Appr : H5P - Vidéo interactive enrichie 41

Ajouter des interactions à une vidéo

♣ Conception : Page d’accueil d’une UE→ Activer le mode édition→ Ajouter une activité→
éditeur = Interactive Video → Titre

→ Ajouter une vidéo → Titre de la vidéo interactive → Image à la une → Options
générales

→ Ajouter des interactions (à glisser-déposer sur la vidéo) → Label → Text → Table →
Link → Image → Statements → QCU → QCM → True/False → Fill in the blanks →
Drag and Drop → Mark the Words → Drag Text → CrossRoads → Navigation Hotspots

→ Glisser-déposer sur la vidéo → Plage d’apparition → Mettre la vidéo sur pause →
Afficher sous forme de = Bouton ; Cadre → ... → Commentaires → Options générales →
Adaptabilité → Valider

→ Récapitulatif → Titre → Texte d’introduction → Résumé = Texte ; Défaut → Ajouter
Affirmations → Indice → Ajouter Intervalle de score → Afficher à (nombre de seconde
avant la fin de la vidéo) → Enregistrer
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@Appr : H5P - Branching Scenario 42

Ajouter des ramifications à un scénario pédagogique

♣ Conception : Page d’accueil d’une UE→ Activer le mode édition→ Ajouter une activité→
éditeur = Branching Scenario → Titre

→ Create Content (à glisser-déposer sur le bouton + ) → Course Presentation → Text

→ Image → Image Hotspots → Interactive Vidéo → Vidéo → Branching Question

→ Settings → Titre de l’écran de départ → Sous-titre de l’écran de départ → Image de
l’écran de départ → Écran de fin (titre, sous-titre, image) → Option de notation

→ Get Help (lire le tutoriel) → Enregistrer
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@Appr : H5P - Timeline (frise chronologique) 43

Communiquer sur des repères temporels

♣ Conception : Page d’accueil d’une UE→ Activer le mode édition→ Ajouter une activité→
éditeur = Timeline→ Titre→ Corps du texte→ Niveau de zoom par défaut = 4→ Image
d’arrière-plan = Vide / Ajouter

→ Media → Date de début → Date de fin → Titre → Texte → Étiquette → Sous-média
→ URL vers un média → Ajouter Image miniature → Crédits du fichier média → Légende

→ Périodes → Date de début → Date de fin → Titre → Contenu → Étiquette →
Enregistrer

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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@Appr : Activité - Leçon 44

Conception

♣ Pour transmettre des savoir-faire granulés, contrôlés et remédiés, donnant lieu à des
progressions personnalisées.

♣ Mise en œuvre : Activer le mode édition → Ajouter une activité → Type = Leçon → Nom
→ Paramètres → Enregistrer et afficher → Ajouter une table de contenu → Titre →
Contenu→ Contenu1,2,3. . .→ Enregistrer→ Ajouter une page question→ Type = Choix
multiple ; Composition ; Correspondant ; Numérique ; Réponse courte ; Vrai/Faux →
Enregistrer → Feedback bonne/mauvaise réponse → Ajouter une fin de branchement

Chaque table correspond à une partie indépendante de la leçon. Les contenus sont les
objectifs poursuivis dans la partie. Les pages questions dématérialisent les grains de
connaissances transmises et leur contrôle. Les paramètres d’une page question scénarisent
les nœuds d’une leçon.

Faire passer un prétest

♣ Procéder à un test de positionnement vis-à-vis d’objectifs poursuivis.

♣ Mise en œuvre : Ajouter une page question → Type = Vrai / Faux → Titre →
Description → Feedback réponse correcte → Feedback mauvaise réponse → Aller à la
question suivante quelque soit la réponse → Enregistrer la page
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@Appr : Activité - Leçon 45

Conception

♣ Pour transmettre des savoir-faire granulés, contrôlés et remédiés, donnant lieu à des
progressions personnalisées.

♣ Mise en œuvre : Activer le mode édition → Ajouter une activité → Type = Leçon → Nom
→ Paramètres → Enregistrer et afficher → Ajouter une table de contenu → Titre →
Contenu→ Contenu1,2,3. . .→ Enregistrer→ Ajouter une page question→ Type = Choix
multiple ; Composition ; Correspondant ; Numérique ; Réponse courte ; Vrai/Faux →
Enregistrer → Feedback bonne/mauvaise réponse → Ajouter une fin de branchement

Chaque table correspond à une partie indépendante de la leçon. Les contenus sont les
objectifs poursuivis dans la partie. Les pages questions dématérialisent les grains de
connaissances transmises et leur contrôle. Les paramètres d’une page question scénarisent
les nœuds d’une leçon.

Faire passer un prétest

♣ Procéder à un test de positionnement vis-à-vis d’objectifs poursuivis.

♣ Mise en œuvre : Ajouter une page question → Type = Vrai / Faux → Titre →
Description → Feedback réponse correcte → Feedback mauvaise réponse → Aller à la
question suivante quelque soit la réponse → Enregistrer la page
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Préacquis et prise en mains de Moodle
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@Appr : Activité - Devoir 46

Dépôt de documents

♣ Préparer un document électronique (de n’importe quel format) à déposer sur le serveur

♣ Conception : Page d’accueil de l’UE → Activer le mode édition → Ajouter une activité →
Nom → Description → Dépôt avancé de fichiers = Texte en ligne ; Activité hors ligne →
Nom → Description → Note → Enregistrer et revenir au cours

Noter les travaux remis
♣ Noter un devoir avec une grille d’évaluation

♣ Mise en œuvre : Paramètres du devoir → Note → Méthode d’évaluation = Grille
d’évaluation→ Enregistrer les modifications→ Évaluation avancée→ Définir un formulaire
d’évaluation → Ajouter critères → Cliquer pour modifier le niveau → Enregistrer la grille et
la rendre prête à l’usage → Consulter les travaux remis → Note → Utiliser la grille
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@Appr : Activité - Devoir 47

Dépôt de documents

♣ Préparer un document électronique (de n’importe quel format) à déposer sur le serveur

♣ Conception : Page d’accueil de l’UE → Activer le mode édition → Ajouter une activité →
Nom → Description → Dépôt avancé de fichiers = Texte en ligne ; Activité hors ligne →
Nom → Description → Note → Enregistrer et revenir au cours

Noter les travaux remis
♣ Noter un devoir avec une grille d’évaluation

♣ Mise en œuvre : Paramètres du devoir → Note → Méthode d’évaluation = Grille
d’évaluation→ Enregistrer les modifications→ Évaluation avancée→ Définir un formulaire
d’évaluation → Ajouter critères → Cliquer pour modifier le niveau → Enregistrer la grille et
la rendre prête à l’usage → Consulter les travaux remis → Note → Utiliser la grille

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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@Appr : Activité - Test (types de questions) 48

Groupe d’exercices 1 Groupe d’exercices 2
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@Appr : Activité - Test (question cloze) 49

Types de trous dans un texte

♣ Principe - Utiliser des codes spécifiques pour générer des trous de types questions à choix
multiples, des questions à réponses courtes et des questions numériques intégrées.

♣ Conception - Page d’accueil de l’UE → Créer une question → Choisir un type de question à
ajouter → Question cloze → Catégorie → Nom → Énoncé → Feedback général →
Décoder et vérifier le texte → Enregistrer

♣ Syntaxe des trous - { nbre-max-points : type-de-trou : = bonne-réponse ] feedback1 ∼ %
pourcentage1 % réponse2 ] feedback2 ∼ ... ∼ % pourcentageN % réponseN ] feedbackN }

types de trous : SA ou SAC (réponses courtes sans/avec casse), MC, MCV ou MCH (choix
multiples en liste déroulante ou boutons-radio horizontaux ou verticaux)

♣ NM (réponses numériques)

{ nbre-max-points : NM : = bonne-réponse : tolérance ] feedback1 ∼ % pourcentage1 %
réponse2 : tolérance2 ] feedback2 ∼ ... ∼ % pourcentageN % réponseN : toléranceN ]
feedbackN }
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@Appr : Activité - Test (question cloze) 50

Types de trous dans un texte

♣ Principe - Utiliser des codes spécifiques pour générer des trous de types questions à choix
multiples, des questions à réponses courtes et des questions numériques intégrées.

♣ Conception - Page d’accueil de l’UE → Créer une question → Choisir un type de question à
ajouter → Question cloze → Catégorie → Nom → Énoncé → Feedback général →
Décoder et vérifier le texte → Enregistrer

♣ Syntaxe des trous - { nbre-max-points : type-de-trou : = bonne-réponse ] feedback1 ∼ %
pourcentage1 % réponse2 ] feedback2 ∼ ... ∼ % pourcentageN % réponseN ] feedbackN }

types de trous : SA ou SAC (réponses courtes sans/avec casse), MC, MCV ou MCH (choix
multiples en liste déroulante ou boutons-radio horizontaux ou verticaux)

♣ NM (réponses numériques)

{ nbre-max-points : NM : = bonne-réponse : tolérance ] feedback1 ∼ % pourcentage1 %
réponse2 : tolérance2 ] feedback2 ∼ ... ∼ % pourcentageN % réponseN : toléranceN ]
feedbackN }

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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@Appr : Activité - Test (question cloze) 51

Types de trous dans un texte

♣ Principe - Utiliser des codes spécifiques pour générer des trous de types questions à choix
multiples, des questions à réponses courtes et des questions numériques intégrées.

♣ Conception - Page d’accueil de l’UE → Créer une question → Choisir un type de question à
ajouter → Question cloze → Catégorie → Nom → Énoncé → Feedback général →
Décoder et vérifier le texte → Enregistrer

♣ Syntaxe des trous - { nbre-max-points : type-de-trou : = bonne-réponse ] feedback1 ∼ %
pourcentage1 % réponse2 ] feedback2 ∼ ... ∼ % pourcentageN % réponseN ] feedbackN }

types de trous : SA ou SAC (réponses courtes sans/avec casse), MC, MCV ou MCH (choix
multiples en liste déroulante ou boutons-radio horizontaux ou verticaux)

♣ NM (réponses numériques)

{ nbre-max-points : NM : = bonne-réponse : tolérance ] feedback1 ∼ % pourcentage1 %
réponse2 : tolérance2 ] feedback2 ∼ ... ∼ % pourcentageN % réponseN : toléranceN ]
feedbackN }
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@Appr : Activité - Test (question cloze) 52

Types de trous dans un texte

♣ Principe - Utiliser des codes spécifiques pour générer des trous de types questions à choix
multiples, des questions à réponses courtes et des questions numériques intégrées.

♣ Conception - Page d’accueil de l’UE → Créer une question → Choisir un type de question à
ajouter → Question cloze → Catégorie → Nom → Énoncé → Feedback général →
Décoder et vérifier le texte → Enregistrer

♣ Syntaxe des trous - { nbre-max-points : type-de-trou : = bonne-réponse ] feedback1 ∼ %
pourcentage1 % réponse2 ] feedback2 ∼ ... ∼ % pourcentageN % réponseN ] feedbackN }

types de trous : SA ou SAC (réponses courtes sans/avec casse), MC, MCV ou MCH (choix
multiples en liste déroulante ou boutons-radio horizontaux ou verticaux)

♣ NM (réponses numériques)

{ nbre-max-points : NM : = bonne-réponse : tolérance ] feedback1 ∼ % pourcentage1 %
réponse2 : tolérance2 ] feedback2 ∼ ... ∼ % pourcentageN % réponseN : toléranceN ]
feedbackN }
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@Appr : Activité - Test (glisser-déposer sur image) 53

Annoter une image

♣ Principe - Faire glisser des groupes de mots ou d’images sur des zones d’une image de fond.

♣ Conception - Page d’accueil du test → Paramètres → Modifier le test → Ajouter une
question → Glisser-déposer sur une image → Nom → Texte de la question → Feedback
général → Aperçu → Image de fond → Éléments à glisser-déposer → Type = Image ;
Texte → Groupe = A ; B → Texte à glisser-déposer → Zones de glisser-déposer →
Sélectionner successivement les éléments définis pour les faire aparâıtre sous l’image de fond

→ Retourner sur l’aperçu → Glisser les éléments sous l’image de fond sur leurs
emplacements exacts pour les marquer et remplir automatiquement les champs Gauche et
Haut correspondants → Feedback combiné → Tentatives multiples → Enregistrer
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@Appr : Activité - Test (glisser-déposer sur image) 54

Annoter une image

♣ Principe - Faire glisser des groupes de mots ou d’images sur des zones d’une image de fond.

♣ Conception - Page d’accueil du test → Paramètres → Modifier le test → Ajouter une
question → Glisser-déposer sur une image → Nom → Texte de la question → Feedback
général → Aperçu → Image de fond → Éléments à glisser-déposer → Type = Image ;
Texte → Groupe = A ; B → Texte à glisser-déposer → Zones de glisser-déposer →
Sélectionner successivement les éléments définis pour les faire aparâıtre sous l’image de fond

→ Retourner sur l’aperçu → Glisser les éléments sous l’image de fond sur leurs
emplacements exacts pour les marquer et remplir automatiquement les champs Gauche et
Haut correspondants → Feedback combiné → Tentatives multiples → Enregistrer
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@Appr : Partage de questions de tests 55

Banque de questions

Principe - Dépôt en partage sur le système de questions ayant servi dans un questionnaire
de test

♣ Export depuis une BDD : Page d’accueil d’une UE ou du site → Réglages → Banque de
questions → Exporter → Format XML Moodle → Choisir la catégorie dans laquelle se
trouve les questions à exporter → Cliquer sur ”Exporter des questions vers un fichier” →
Continuer

♣ Import dans une BDD : Page d’accueil d’une UE ou du site → Réglages → Banque de
questions → Importer → Format XML Moodle → Choisir ”défaut pour système” → Choisir
le fichier exporté précédemment → Cliquer sur ”Importation” → Continuer
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@Appr : Partage de questions de tests 56

Banque de questions

Principe - Dépôt en partage sur le système de questions ayant servi dans un questionnaire
de test

♣ Export depuis une BDD : Page d’accueil d’une UE ou du site → Réglages → Banque de
questions → Exporter → Format XML Moodle → Choisir la catégorie dans laquelle se
trouve les questions à exporter → Cliquer sur ”Exporter des questions vers un fichier” →
Continuer

♣ Import dans une BDD : Page d’accueil d’une UE ou du site → Réglages → Banque de
questions → Importer → Format XML Moodle → Choisir ”défaut pour système” → Choisir
le fichier exporté précédemment → Cliquer sur ”Importation” → Continuer
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@Appr : Partage de questions de tests 57

Banque de questions

Principe - Dépôt en partage sur le système de questions ayant servi dans un questionnaire
de test

♣ Export depuis une BDD : Page d’accueil d’une UE ou du site → Réglages → Banque de
questions → Exporter → Format XML Moodle → Choisir la catégorie dans laquelle se
trouve les questions à exporter → Cliquer sur ”Exporter des questions vers un fichier” →
Continuer

♣ Import dans une BDD : Page d’accueil d’une UE ou du site → Réglages → Banque de
questions → Importer → Format XML Moodle → Choisir ”défaut pour système” → Choisir
le fichier exporté précédemment → Cliquer sur ”Importation” → Continuer

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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@Appr : Test - Examen en ligne avec SEB 58

Paramétrages initiaux

♣ Paramétrages pour organiser un test en ligne sur un navigateur sécurisé (occupe la totalité
de l’écran, sans pouvoir être réduit, n’autorise aucune bascule vers une autre application
telles que la messagerie et autres)

– Administration du site → Développement → Réglages expérimentaux → Activer
l’intégration de Safe Exam Browser = Coché → Enregistrer les modifications

– Paramètres du test → Safe Exam Browser → Require the use of Safe Exam Browser = Yes
- Use SEB client config→ Allowed Browser Exam Keys = ...→ Enregistrer les modifications
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@Appr : Ateliers 59

Évaluation par les pairs

♣ Principe - Évaluer en 5 étapes les travaux de
membres d’un groupe, en utilisant différentes
stratégies. La gestion des travaux remis est
automatique : collecte et distribution des travaux,
affichage des résultats, etc.

♣ Conception - Page d’accueil de l’UE → Activer le
mode édition → Ajouter une activité → Atelier →
Nom → Introduction → Utiliser les évaluations par
les pairs → Note maximale pour le travail remis →
Note maximale pour l’évaluation de travaux →
Instructions pour la remise de travaux →
Instructions pour l’évaluation de travaux →
Enregistrer et revenir au cours

♣ Mise en œuvre - Cliquer sur l’ampoule pour activer
la phase suivante, après que chaque tâche ait été
cochée par Moodle → Suivre les instructions
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@Appr : Ateliers 60

Évaluation par les pairs

♣ Principe - Évaluer en 5 étapes les travaux de
membres d’un groupe, en utilisant différentes
stratégies. La gestion des travaux remis est
automatique : collecte et distribution des travaux,
affichage des résultats, etc.

♣ Conception - Page d’accueil de l’UE → Activer le
mode édition → Ajouter une activité → Atelier →
Nom → Introduction → Utiliser les évaluations par
les pairs → Note maximale pour le travail remis →
Note maximale pour l’évaluation de travaux →
Instructions pour la remise de travaux →
Instructions pour l’évaluation de travaux →
Enregistrer et revenir au cours

♣ Mise en œuvre - Cliquer sur l’ampoule pour activer
la phase suivante, après que chaque tâche ait été
cochée par Moodle → Suivre les instructions
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@Appr : Ateliers 61

Évaluation par les pairs

♣ Principe - Évaluer en 5 étapes les travaux de
membres d’un groupe, en utilisant différentes
stratégies. La gestion des travaux remis est
automatique : collecte et distribution des travaux,
affichage des résultats, etc.

♣ Conception - Page d’accueil de l’UE → Activer le
mode édition → Ajouter une activité → Atelier →
Nom → Introduction → Utiliser les évaluations par
les pairs → Note maximale pour le travail remis →
Note maximale pour l’évaluation de travaux →
Instructions pour la remise de travaux →
Instructions pour l’évaluation de travaux →
Enregistrer et revenir au cours

♣ Mise en œuvre - Cliquer sur l’ampoule pour activer
la phase suivante, après que chaque tâche ait été
cochée par Moodle → Suivre les instructions
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@Appr : Scénarisation d’activités 62

Paramétrages initiaux

♣ Activités (disponibilité et achèvement) : Réglages → Administration du site → Fonctions
avancées → Activer le suivi de l’achèvement des activités → Activer la disponibilité
conditionnelle → Enregistrer les modifications

♣ Réglages → Administration du site → Cours → Réglages par défaut des cours → Activer le
suivi d’achèvement dès l’inscription au cours → Enregistrer les modifications

Jeux de permissions

♣ Page d’accueil du cours → Activer le mode édition → Modifier les paramètres de chaque
activité du dispositif

♣ Dépend de : l’accès à une leçon dépend des résultats de l’étudiant dans une autre leçon. Les
conditions applicables sont : Durée utilisée (passer au moins cette durée sur la leçon
considérée), Terminé (terminer la leçon considérée), Note plus haute que (la note obtenue
supérieure à la note définie ici).

♣ Restreindre la disponibilité : Les conditions applicables sont : Conditions de note (rendre
une activité disponible), Condition de fin d’activité (marquer une activité comme étant
terminée).

♣ Achèvement d’activité : Les conditions applicables sont : Suivi d’achèvement (manuel ou
automatique), Note requise (note avec affichage d’icônes de réussite ou d’échec).
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@Appr : Scénarisation d’activités 63

Paramétrages initiaux

♣ Activités (disponibilité et achèvement) : Réglages → Administration du site → Fonctions
avancées → Activer le suivi de l’achèvement des activités → Activer la disponibilité
conditionnelle → Enregistrer les modifications

♣ Réglages → Administration du site → Cours → Réglages par défaut des cours → Activer le
suivi d’achèvement dès l’inscription au cours → Enregistrer les modifications

Jeux de permissions

♣ Page d’accueil du cours → Activer le mode édition → Modifier les paramètres de chaque
activité du dispositif

♣ Dépend de : l’accès à une leçon dépend des résultats de l’étudiant dans une autre leçon. Les
conditions applicables sont : Durée utilisée (passer au moins cette durée sur la leçon
considérée), Terminé (terminer la leçon considérée), Note plus haute que (la note obtenue
supérieure à la note définie ici).

♣ Restreindre la disponibilité : Les conditions applicables sont : Conditions de note (rendre
une activité disponible), Condition de fin d’activité (marquer une activité comme étant
terminée).

♣ Achèvement d’activité : Les conditions applicables sont : Suivi d’achèvement (manuel ou
automatique), Note requise (note avec affichage d’icônes de réussite ou d’échec).
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@Appr : Scénarisation d’activités 64

Paramétrages initiaux

♣ Activités (disponibilité et achèvement) : Réglages → Administration du site → Fonctions
avancées → Activer le suivi de l’achèvement des activités → Activer la disponibilité
conditionnelle → Enregistrer les modifications

♣ Réglages → Administration du site → Cours → Réglages par défaut des cours → Activer le
suivi d’achèvement dès l’inscription au cours → Enregistrer les modifications

Jeux de permissions

♣ Page d’accueil du cours → Activer le mode édition → Modifier les paramètres de chaque
activité du dispositif

♣ Dépend de : l’accès à une leçon dépend des résultats de l’étudiant dans une autre leçon. Les
conditions applicables sont : Durée utilisée (passer au moins cette durée sur la leçon
considérée), Terminé (terminer la leçon considérée), Note plus haute que (la note obtenue
supérieure à la note définie ici).

♣ Restreindre la disponibilité : Les conditions applicables sont : Conditions de note (rendre
une activité disponible), Condition de fin d’activité (marquer une activité comme étant
terminée).

♣ Achèvement d’activité : Les conditions applicables sont : Suivi d’achèvement (manuel ou
automatique), Note requise (note avec affichage d’icônes de réussite ou d’échec).
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Paramétrages initiaux

♣ Activités (disponibilité et achèvement) : Réglages → Administration du site → Fonctions
avancées → Activer le suivi de l’achèvement des activités → Activer la disponibilité
conditionnelle → Enregistrer les modifications

♣ Réglages → Administration du site → Cours → Réglages par défaut des cours → Activer le
suivi d’achèvement dès l’inscription au cours → Enregistrer les modifications

Jeux de permissions

♣ Page d’accueil du cours → Activer le mode édition → Modifier les paramètres de chaque
activité du dispositif

♣ Dépend de : l’accès à une leçon dépend des résultats de l’étudiant dans une autre leçon. Les
conditions applicables sont : Durée utilisée (passer au moins cette durée sur la leçon
considérée), Terminé (terminer la leçon considérée), Note plus haute que (la note obtenue
supérieure à la note définie ici).

♣ Restreindre la disponibilité : Les conditions applicables sont : Conditions de note (rendre
une activité disponible), Condition de fin d’activité (marquer une activité comme étant
terminée).

♣ Achèvement d’activité : Les conditions applicables sont : Suivi d’achèvement (manuel ou
automatique), Note requise (note avec affichage d’icônes de réussite ou d’échec).
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Paramétrages initiaux

♣ Activités (disponibilité et achèvement) : Réglages → Administration du site → Fonctions
avancées → Activer le suivi de l’achèvement des activités → Activer la disponibilité
conditionnelle → Enregistrer les modifications

♣ Réglages → Administration du site → Cours → Réglages par défaut des cours → Activer le
suivi d’achèvement dès l’inscription au cours → Enregistrer les modifications

Jeux de permissions

♣ Page d’accueil du cours → Activer le mode édition → Modifier les paramètres de chaque
activité du dispositif

♣ Dépend de : l’accès à une leçon dépend des résultats de l’étudiant dans une autre leçon. Les
conditions applicables sont : Durée utilisée (passer au moins cette durée sur la leçon
considérée), Terminé (terminer la leçon considérée), Note plus haute que (la note obtenue
supérieure à la note définie ici).

♣ Restreindre la disponibilité : Les conditions applicables sont : Conditions de note (rendre
une activité disponible), Condition de fin d’activité (marquer une activité comme étant
terminée).

♣ Achèvement d’activité : Les conditions applicables sont : Suivi d’achèvement (manuel ou
automatique), Note requise (note avec affichage d’icônes de réussite ou d’échec).
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Carnet des notes
♣ Définir un barème - Administration du site → Notes → Barèmes → Ajouter un nouveau

barème → Nom → Valeurs du barème → Description du contexte d’utilisation →
Enregistrer → Choix dans les paramètres d’activités évaluées

♣ Relevés/Exports de notes - Réglages → Notes → Affichage → Rapport d’ensemble →
Sélectionner un utilisateur → Exporter → Feuille de calcul ODT/XLS

♣ Ajout de moyennes partielles (=sum/average([[elt1]] ;[[elt2]]...) ; +, /, ?) - Réglages →
Notes → Affichage simple : Catégories et éléments → Ajouter un élément d’évaluation →
Nom → Enregistrer → Modifier le calcul → Formule de calcul → Enregistrer → Idenfiants
→ Ajouter les identifiants → Enregistrer

♣ Ajout de catégories (segmenter l’affichage de l’évaluateur) - Réglages → Notes →
Affichage simple : Catégories et éléments → Ajouter une catégorie → Nom → Enregistrer
→ Glisser/déposer les éléments dans la catégorie
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Carnet des notes
♣ Définir un barème - Administration du site → Notes → Barèmes → Ajouter un nouveau

barème → Nom → Valeurs du barème → Description du contexte d’utilisation →
Enregistrer → Choix dans les paramètres d’activités évaluées

♣ Relevés/Exports de notes - Réglages → Notes → Affichage → Rapport d’ensemble →
Sélectionner un utilisateur → Exporter → Feuille de calcul ODT/XLS

♣ Ajout de moyennes partielles (=sum/average([[elt1]] ;[[elt2]]...) ; +, /, ?) - Réglages →
Notes → Affichage simple : Catégories et éléments → Ajouter un élément d’évaluation →
Nom → Enregistrer → Modifier le calcul → Formule de calcul → Enregistrer → Idenfiants
→ Ajouter les identifiants → Enregistrer

♣ Ajout de catégories (segmenter l’affichage de l’évaluateur) - Réglages → Notes →
Affichage simple : Catégories et éléments → Ajouter une catégorie → Nom → Enregistrer
→ Glisser/déposer les éléments dans la catégorie
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Carnet des notes
♣ Définir un barème - Administration du site → Notes → Barèmes → Ajouter un nouveau

barème → Nom → Valeurs du barème → Description du contexte d’utilisation →
Enregistrer → Choix dans les paramètres d’activités évaluées

♣ Relevés/Exports de notes - Réglages → Notes → Affichage → Rapport d’ensemble →
Sélectionner un utilisateur → Exporter → Feuille de calcul ODT/XLS

♣ Ajout de moyennes partielles (=sum/average([[elt1]] ;[[elt2]]...) ; +, /, ?) - Réglages →
Notes → Affichage simple : Catégories et éléments → Ajouter un élément d’évaluation →
Nom → Enregistrer → Modifier le calcul → Formule de calcul → Enregistrer → Idenfiants
→ Ajouter les identifiants → Enregistrer

♣ Ajout de catégories (segmenter l’affichage de l’évaluateur) - Réglages → Notes →
Affichage simple : Catégories et éléments → Ajouter une catégorie → Nom → Enregistrer
→ Glisser/déposer les éléments dans la catégorie
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Carnet des notes
♣ Définir un barème - Administration du site → Notes → Barèmes → Ajouter un nouveau

barème → Nom → Valeurs du barème → Description du contexte d’utilisation →
Enregistrer → Choix dans les paramètres d’activités évaluées

♣ Relevés/Exports de notes - Réglages → Notes → Affichage → Rapport d’ensemble →
Sélectionner un utilisateur → Exporter → Feuille de calcul ODT/XLS

♣ Ajout de moyennes partielles (=sum/average([[elt1]] ;[[elt2]]...) ; +, /, ?) - Réglages →
Notes → Affichage simple : Catégories et éléments → Ajouter un élément d’évaluation →
Nom → Enregistrer → Modifier le calcul → Formule de calcul → Enregistrer → Idenfiants
→ Ajouter les identifiants → Enregistrer

♣ Ajout de catégories (segmenter l’affichage de l’évaluateur) - Réglages → Notes →
Affichage simple : Catégories et éléments → Ajouter une catégorie → Nom → Enregistrer
→ Glisser/déposer les éléments dans la catégorie
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Discussions synchrones par écrit

♣ Principe - Avoir une discussion synchrone en temps réel via le Web

♣ Conception : Page d’accueil de l’UE → Activer le mode édition → Ajouter une activité →
Chat → Nom → Texte d’introduction → Enregistrer et revenir au cours → Clic sur le chat
→ Cliquer ici pour participer au chat → Taper votre message → Envoyer → Fermer

Discussions asynchrones par écrit

♣ Principe - Salon de discussion asynchrone, avec la possibilité de recevoir par courriel
chaque nouvelle contribution

♣ Conception : Page d’accueil de l’UE → Activer le mode édition → Ajouter une activité →
Forum → Nom → Type de forum → Introduction au forum → Mode d’abonnement →
Enregistrer et revenir au cours → Clic sur le forum → Ajouter un nouveau sujet de
discussion → Sujet → Message → Annexe → Envoyer → Choisir le salon → Répondre
→Message de réponse → Envoyer
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Discussions synchrones par écrit

♣ Principe - Avoir une discussion synchrone en temps réel via le Web

♣ Conception : Page d’accueil de l’UE → Activer le mode édition → Ajouter une activité →
Chat → Nom → Texte d’introduction → Enregistrer et revenir au cours → Clic sur le chat
→ Cliquer ici pour participer au chat → Taper votre message → Envoyer → Fermer

Discussions asynchrones par écrit

♣ Principe - Salon de discussion asynchrone, avec la possibilité de recevoir par courriel
chaque nouvelle contribution

♣ Conception : Page d’accueil de l’UE → Activer le mode édition → Ajouter une activité →
Forum → Nom → Type de forum → Introduction au forum → Mode d’abonnement →
Enregistrer et revenir au cours → Clic sur le forum → Ajouter un nouveau sujet de
discussion → Sujet → Message → Annexe → Envoyer → Choisir le salon → Répondre
→Message de réponse → Envoyer

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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Salon audiovisuel synchrone

♣ Fonctionnalités - Gestion de planning et d’invitation aux réunions, liaison audio et vidéo,
tableau blanc virtuel et diaporama, partage d’applications et de documents, messagerie
instantanée, enregistrement et archivage.

♣ Conception : Page d’accueil de l’UE → Activer le mode édition → Ajouter une activité →
Jitsi → Nom → Description → Disponibilité → Enregistrer et revenir au cours → Clic sur
l’activité Webconférence → Accéder → Muet/Actif → Démarrer/Arrêter la caméra →
Ouvrir/fermer le chat → Partager son écran → Inviter des participants → Régler les
paramètres

Écriture Web collective

♣ Principe - Édition collaborative à plusieurs de pages Web, incluant l’historique des
modifications et les cartes des contributions, des liens, des pages orphelines et de l’index des
pages.

♣ Conception : Page d’accueil de l’UE → Activer le mode édition → Ajouter une activité →
Wiki → Nom → Description → Nom de la 1re page → Enregistrer et revenir au cours →
Clic sur le wiki → Créer une page → Inscrire sa contribution → Enregistrer
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@Appr : Activités - Webconférence / Wiki 75

Salon audiovisuel synchrone

♣ Fonctionnalités - Gestion de planning et d’invitation aux réunions, liaison audio et vidéo,
tableau blanc virtuel et diaporama, partage d’applications et de documents, messagerie
instantanée, enregistrement et archivage.

♣ Conception : Page d’accueil de l’UE → Activer le mode édition → Ajouter une activité →
Jitsi → Nom → Description → Disponibilité → Enregistrer et revenir au cours → Clic sur
l’activité Webconférence → Accéder → Muet/Actif → Démarrer/Arrêter la caméra →
Ouvrir/fermer le chat → Partager son écran → Inviter des participants → Régler les
paramètres

Écriture Web collective

♣ Principe - Édition collaborative à plusieurs de pages Web, incluant l’historique des
modifications et les cartes des contributions, des liens, des pages orphelines et de l’index des
pages.

♣ Conception : Page d’accueil de l’UE → Activer le mode édition → Ajouter une activité →
Wiki → Nom → Description → Nom de la 1re page → Enregistrer et revenir au cours →
Clic sur le wiki → Créer une page → Inscrire sa contribution → Enregistrer

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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Proposer des enquêtes d’opinion

♣ Principe - Créer des questionnaires personnalisés (indicatifs ou non)

♣ Conception : Page d’accueil de l’UE → Activer le mode édition → Ajouter une activité →
Feedback → Nom → Description → Ouvrir le feedback → Fermer le feedback → Page
affichée après envoi du formulaire → Enregistrer et revenir au cours → Clic sur l’activité
feedback → Modifier les questions → Sélectionner le type de question → Ajouter une
question

Votes et consensus
♣ Principe - Ouvrir un scrutin aux participants d’une unité d’enseignement, avec possibilité

d’export du résultat du vote

♣ Conception : Page d’accueil de l’UE → Activer le mode édition → Ajouter une activité →
Sondage → Nom → Texte d’introduction → Option 1,2,. . .→ Publication des résultats =
Toujours afficher les résultats aux étudiants → Confidentialité des résultats = Publier les
résultats anonymement → Enregistrer et revenir au cours → Clic sur le sondage →
Enregistrer mon choix → Voir les réponses → Télécharger en format Excel/ODS/texte
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@Appr : Activités - Feedback / Sondage 77

Proposer des enquêtes d’opinion

♣ Principe - Créer des questionnaires personnalisés (indicatifs ou non)

♣ Conception : Page d’accueil de l’UE → Activer le mode édition → Ajouter une activité →
Feedback → Nom → Description → Ouvrir le feedback → Fermer le feedback → Page
affichée après envoi du formulaire → Enregistrer et revenir au cours → Clic sur l’activité
feedback → Modifier les questions → Sélectionner le type de question → Ajouter une
question

Votes et consensus
♣ Principe - Ouvrir un scrutin aux participants d’une unité d’enseignement, avec possibilité

d’export du résultat du vote

♣ Conception : Page d’accueil de l’UE → Activer le mode édition → Ajouter une activité →
Sondage → Nom → Texte d’introduction → Option 1,2,. . .→ Publication des résultats =
Toujours afficher les résultats aux étudiants → Confidentialité des résultats = Publier les
résultats anonymement → Enregistrer et revenir au cours → Clic sur le sondage →
Enregistrer mon choix → Voir les réponses → Télécharger en format Excel/ODS/texte

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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@Appr : Partager le dispositif éducatif 78

Partager un cours

♣ Sauvegarde - Page d’accueil du cours → Gestion du cours → Sauvegarde → Décocher les
participants → Suivant → Effectuer la sauvegarde → Télécharcher le fichier .mbz

♣ Restauration - Administration du site → Cours → Restaurer un cours → Déposer le fichier
.mbz → Comme nouveau cours / Fusionner avec un cours existant → Choisir la catégorie
→ Suivant → Cours restauré avec succès

♣ Exporter/Importer les articles d’un glossaire - Page d’accueil du glossaire → Paramètres
→ Exporter/Importer les articles → Dans/Déposer un fichier .xml → Enregistrer/Importer

Partager ses ressources et activités

♣ Partager une section avec ”Block Sharing Cart” - Page d’accueil du cours → Activer le
mode édition → Ajouter un bloc → Panier d’activités → Configurer le bloc → Choisir les
titres de sections à partager → Elles sont alors disponibles dans tout autre cours pour
importation

♣ Partager une ressource/activité - Page d’accueil du cours → Activer le mode édition →
Cliquer sur l’icône Copier dans le panier d’activités à droite en face de la ressource ou de
l’activité à partager → Elle est alors disponible dans tout autre cours pour importation
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Partager un cours

♣ Sauvegarde - Page d’accueil du cours → Gestion du cours → Sauvegarde → Décocher les
participants → Suivant → Effectuer la sauvegarde → Télécharcher le fichier .mbz

♣ Restauration - Administration du site → Cours → Restaurer un cours → Déposer le fichier
.mbz → Comme nouveau cours / Fusionner avec un cours existant → Choisir la catégorie
→ Suivant → Cours restauré avec succès

♣ Exporter/Importer les articles d’un glossaire - Page d’accueil du glossaire → Paramètres
→ Exporter/Importer les articles → Dans/Déposer un fichier .xml → Enregistrer/Importer

Partager ses ressources et activités

♣ Partager une section avec ”Block Sharing Cart” - Page d’accueil du cours → Activer le
mode édition → Ajouter un bloc → Panier d’activités → Configurer le bloc → Choisir les
titres de sections à partager → Elles sont alors disponibles dans tout autre cours pour
importation

♣ Partager une ressource/activité - Page d’accueil du cours → Activer le mode édition →
Cliquer sur l’icône Copier dans le panier d’activités à droite en face de la ressource ou de
l’activité à partager → Elle est alors disponible dans tout autre cours pour importation
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Préacquis et prise en mains de Moodle
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Inscription par lots

♣ Les gestionnaires préparent des groupes d’utilisateurs à inscrire par lot dans des unités
d’enseignements

♣ Cohortes : Administration du site → Plugins → Inscriptions → Gérer les plugins
d’inscription → Activer, Synchronisation des cohortes

– Administration du site → Utilisateurs → Comptes → Cohortes → Ajouter → Nom →
Contexte → Identifiant cohorte → Description → Enregistrer → Ajouter membres →
Sélectionner utilisateurs potentiels → Ajouter

– Page d’accueil de l’UE → Réglages → Utilisateurs → Méthodes d’inscription → Ajouter
méthode → Choisir synchronisation des cohortes → Choix de la cohorte

– Page d’accueil de l’UE → Réglages → Utilisateurs → Utilisateurs inscrits → Inscrire une
cohorte/un utilisateur
(Inscrire un utilisateur correspond à l’inscription d’une cohorte ne comprenant qu’un seul
membre)
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Communication
♣ Diffuser les activités de l’UE ou connexes, chronologiquement, par type, sous différentes

vues (quotidienne, mensuelle)

♣ Calendrier (push) : Page d’accueil de l’UE → Bloc, Événements à venir → Nouvel
événement → Type d’événement = Utilisateur/Cours/Site → Nom → Description → Date
→ Durée → Enregistrer
(le type d’événement, Site, est réservé aux administrateurs)

♣ Flux RSS (pull) : Administration du site → Fonctions avancées → Cocher, Activer les RSS
→ Enregistrer les modifications

Administration du site → Plugins → Blocs → Client RSS → Articles par flux → Durée de
vie → Ajouter/modifier des flux → Enregistrer les modifications

Page d’accueil de l’UE → Ajouter un bloc → Flux RSS → Configurer le bloc, Flux RSS
distants → Choisir les flux RSS à afficher dans la liste disponible → Titre → Enregistrer
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@Appr : Construire ensemble des compétences 83

Socioconstructivisme
♣ Transmission nourrit l’apprentissage

♣ Construction de compétences à
travers des activités métiers

♣ Chronologie des compétences

♣ Scénarisation des activités
(Poelhuber)

Acquisition d’une compétence

♣ Phase d’exploration (par l’objectif)

♣ Apprentissage de base (habiletés)

♣ Phase d’intégration (feedbacks)

♣ Transfert (exigences de la profession)

♣ Enrichissement (amélioration
continue)

Schéma procédural
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Médiatisation des aires d’apprentissage

Médiation tutorée d’apprentissage
Conducteur pédagogique

@Appr : Construire ensemble des compétences 84

Socioconstructivisme
♣ Transmission nourrit l’apprentissage

♣ Construction de compétences à
travers des activités métiers

♣ Chronologie des compétences

♣ Scénarisation des activités
(Poelhuber)

Acquisition d’une compétence

♣ Phase d’exploration (par l’objectif)

♣ Apprentissage de base (habiletés)

♣ Phase d’intégration (feedbacks)

♣ Transfert (exigences de la profession)

♣ Enrichissement (amélioration
continue)

Schéma procédural

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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R. Mager

♣ Comportement, mesurable observable

♣ Capacité à manifester (identification),
critères de réussite (exécution de
l’action)

N. Gronlund
♣ Cognitif, mesurable observable

♣ Objectif général (identification),
résultats spécifiques (exécution de
l’action)

Taxonomie de Bloom revisitée : Anderson et Crathwohl

♣ Se souvenir (récupérer les connaissances pertinentes de sa mémoire à long terme) :
reconnâıtre, se rappeler

♣ Comprendre (déterminer le sens des notions enseignées) : interpréter, illustrer par des
exemples, classifier, résumer, inférer, comparer, expliquer

♣ Appliquer (utiliser une procédure dans une situation donnée) : exécuter, mettre en œuvre

♣ Analyser (décomposer en éléments constitutifs, discerner les relations entre les parties et
percevoir la structure globale) : différencier, organiser, attribuer

♣ Évaluer (porter un jugement critérié et normé) : vérifier, critiquer

♣ Créer (rassembler des éléments de composition, réaliser un tout cohérent, fabriquer un
produit original) : générer, planifier, produire

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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R. Mager

♣ Comportement, mesurable observable

♣ Capacité à manifester (identification),
critères de réussite (exécution de
l’action)

N. Gronlund
♣ Cognitif, mesurable observable

♣ Objectif général (identification),
résultats spécifiques (exécution de
l’action)

Taxonomie de Bloom revisitée : Anderson et Crathwohl

♣ Se souvenir (récupérer les connaissances pertinentes de sa mémoire à long terme) :
reconnâıtre, se rappeler

♣ Comprendre (déterminer le sens des notions enseignées) : interpréter, illustrer par des
exemples, classifier, résumer, inférer, comparer, expliquer

♣ Appliquer (utiliser une procédure dans une situation donnée) : exécuter, mettre en œuvre

♣ Analyser (décomposer en éléments constitutifs, discerner les relations entre les parties et
percevoir la structure globale) : différencier, organiser, attribuer

♣ Évaluer (porter un jugement critérié et normé) : vérifier, critiquer

♣ Créer (rassembler des éléments de composition, réaliser un tout cohérent, fabriquer un
produit original) : générer, planifier, produire

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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R. Mager

♣ Comportement, mesurable observable

♣ Capacité à manifester (identification),
critères de réussite (exécution de
l’action)

N. Gronlund
♣ Cognitif, mesurable observable

♣ Objectif général (identification),
résultats spécifiques (exécution de
l’action)

Taxonomie de Bloom revisitée : Anderson et Crathwohl

♣ Se souvenir (récupérer les connaissances pertinentes de sa mémoire à long terme) :
reconnâıtre, se rappeler

♣ Comprendre (déterminer le sens des notions enseignées) : interpréter, illustrer par des
exemples, classifier, résumer, inférer, comparer, expliquer

♣ Appliquer (utiliser une procédure dans une situation donnée) : exécuter, mettre en œuvre

♣ Analyser (décomposer en éléments constitutifs, discerner les relations entre les parties et
percevoir la structure globale) : différencier, organiser, attribuer

♣ Évaluer (porter un jugement critérié et normé) : vérifier, critiquer

♣ Créer (rassembler des éléments de composition, réaliser un tout cohérent, fabriquer un
produit original) : générer, planifier, produire

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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R. Mager

♣ Comportement, mesurable observable

♣ Capacité à manifester (identification),
critères de réussite (exécution de
l’action)

N. Gronlund
♣ Cognitif, mesurable observable

♣ Objectif général (identification),
résultats spécifiques (exécution de
l’action)

Taxonomie de Bloom revisitée : Anderson et Crathwohl

♣ Se souvenir (récupérer les connaissances pertinentes de sa mémoire à long terme) :
reconnâıtre, se rappeler

♣ Comprendre (déterminer le sens des notions enseignées) : interpréter, illustrer par des
exemples, classifier, résumer, inférer, comparer, expliquer

♣ Appliquer (utiliser une procédure dans une situation donnée) : exécuter, mettre en œuvre

♣ Analyser (décomposer en éléments constitutifs, discerner les relations entre les parties et
percevoir la structure globale) : différencier, organiser, attribuer

♣ Évaluer (porter un jugement critérié et normé) : vérifier, critiquer

♣ Créer (rassembler des éléments de composition, réaliser un tout cohérent, fabriquer un
produit original) : générer, planifier, produire

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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R. Mager

♣ Comportement, mesurable observable

♣ Capacité à manifester (identification),
critères de réussite (exécution de
l’action)

N. Gronlund
♣ Cognitif, mesurable observable

♣ Objectif général (identification),
résultats spécifiques (exécution de
l’action)

Taxonomie de Bloom revisitée : Anderson et Crathwohl

♣ Se souvenir (récupérer les connaissances pertinentes de sa mémoire à long terme) :
reconnâıtre, se rappeler

♣ Comprendre (déterminer le sens des notions enseignées) : interpréter, illustrer par des
exemples, classifier, résumer, inférer, comparer, expliquer

♣ Appliquer (utiliser une procédure dans une situation donnée) : exécuter, mettre en œuvre

♣ Analyser (décomposer en éléments constitutifs, discerner les relations entre les parties et
percevoir la structure globale) : différencier, organiser, attribuer

♣ Évaluer (porter un jugement critérié et normé) : vérifier, critiquer

♣ Créer (rassembler des éléments de composition, réaliser un tout cohérent, fabriquer un
produit original) : générer, planifier, produire

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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R. Mager

♣ Comportement, mesurable observable

♣ Capacité à manifester (identification),
critères de réussite (exécution de
l’action)

N. Gronlund
♣ Cognitif, mesurable observable

♣ Objectif général (identification),
résultats spécifiques (exécution de
l’action)

Taxonomie de Bloom revisitée : Anderson et Crathwohl

♣ Se souvenir (récupérer les connaissances pertinentes de sa mémoire à long terme) :
reconnâıtre, se rappeler

♣ Comprendre (déterminer le sens des notions enseignées) : interpréter, illustrer par des
exemples, classifier, résumer, inférer, comparer, expliquer

♣ Appliquer (utiliser une procédure dans une situation donnée) : exécuter, mettre en œuvre

♣ Analyser (décomposer en éléments constitutifs, discerner les relations entre les parties et
percevoir la structure globale) : différencier, organiser, attribuer

♣ Évaluer (porter un jugement critérié et normé) : vérifier, critiquer

♣ Créer (rassembler des éléments de composition, réaliser un tout cohérent, fabriquer un
produit original) : générer, planifier, produire

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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R. Mager

♣ Comportement, mesurable observable

♣ Capacité à manifester (identification),
critères de réussite (exécution de
l’action)

N. Gronlund
♣ Cognitif, mesurable observable

♣ Objectif général (identification),
résultats spécifiques (exécution de
l’action)

Taxonomie de Bloom revisitée : Anderson et Crathwohl

♣ Se souvenir (récupérer les connaissances pertinentes de sa mémoire à long terme) :
reconnâıtre, se rappeler

♣ Comprendre (déterminer le sens des notions enseignées) : interpréter, illustrer par des
exemples, classifier, résumer, inférer, comparer, expliquer

♣ Appliquer (utiliser une procédure dans une situation donnée) : exécuter, mettre en œuvre

♣ Analyser (décomposer en éléments constitutifs, discerner les relations entre les parties et
percevoir la structure globale) : différencier, organiser, attribuer

♣ Évaluer (porter un jugement critérié et normé) : vérifier, critiquer

♣ Créer (rassembler des éléments de composition, réaliser un tout cohérent, fabriquer un
produit original) : générer, planifier, produire

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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R. Mager

♣ Comportement, mesurable observable

♣ Capacité à manifester (identification),
critères de réussite (exécution de
l’action)

N. Gronlund
♣ Cognitif, mesurable observable

♣ Objectif général (identification),
résultats spécifiques (exécution de
l’action)

Taxonomie de Bloom revisitée : Anderson et Crathwohl

♣ Se souvenir (récupérer les connaissances pertinentes de sa mémoire à long terme) :
reconnâıtre, se rappeler

♣ Comprendre (déterminer le sens des notions enseignées) : interpréter, illustrer par des
exemples, classifier, résumer, inférer, comparer, expliquer

♣ Appliquer (utiliser une procédure dans une situation donnée) : exécuter, mettre en œuvre

♣ Analyser (décomposer en éléments constitutifs, discerner les relations entre les parties et
percevoir la structure globale) : différencier, organiser, attribuer

♣ Évaluer (porter un jugement critérié et normé) : vérifier, critiquer

♣ Créer (rassembler des éléments de composition, réaliser un tout cohérent, fabriquer un
produit original) : générer, planifier, produire

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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Installation de l’hébergeur

♣ Installer les dépendances Java, FlashPlayer et
LibreOffice

♣ Télécharger et installer le logiciel ScenariChain
(www.scenari.org)

sudo gedit /etc/apt/sources.list → deb
http ://scenari-platform.org/deb distrib-ubuntu
main → sudo apt update → sudo apt install
scenarichain4.2.fr-fr

♣ Depuis l’interface graphique ScenariChain

♥ Bouton Installer → Installer un pack → Installer
modèle Opale → Installer extension Basar →
Fermer fenêtre

♥ Bouton Ajouter → Créer un atelier → Code de
l’atelier → Cocher modèle Opale → Cocher
extension Basar → Créer

wsppacks & ateliers

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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Installation de l’hébergeur

♣ Installer les dépendances Java, FlashPlayer et
LibreOffice

♣ Télécharger et installer le logiciel ScenariChain
(www.scenari.org)

sudo gedit /etc/apt/sources.list → deb
http ://scenari-platform.org/deb distrib-ubuntu
main → sudo apt update → sudo apt install
scenarichain4.2.fr-fr

♣ Depuis l’interface graphique ScenariChain

♥ Bouton Installer → Installer un pack → Installer
modèle Opale → Installer extension Basar →
Fermer fenêtre

♥ Bouton Ajouter → Créer un atelier → Code de
l’atelier → Cocher modèle Opale → Cocher
extension Basar → Créer

wsppacks & ateliers

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride

www.scenari.org
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Installation de l’hébergeur

♣ Installer les dépendances Java, FlashPlayer et
LibreOffice

♣ Télécharger et installer le logiciel ScenariChain
(www.scenari.org)

sudo gedit /etc/apt/sources.list → deb
http ://scenari-platform.org/deb distrib-ubuntu
main → sudo apt update → sudo apt install
scenarichain4.2.fr-fr

♣ Depuis l’interface graphique ScenariChain

♥ Bouton Installer → Installer un pack → Installer
modèle Opale → Installer extension Basar →
Fermer fenêtre

♥ Bouton Ajouter → Créer un atelier → Code de
l’atelier → Cocher modèle Opale → Cocher
extension Basar → Créer

wsppacks & ateliers

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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Installation de l’hébergeur

♣ Installer les dépendances Java, FlashPlayer et
LibreOffice

♣ Télécharger et installer le logiciel ScenariChain
(www.scenari.org)

sudo gedit /etc/apt/sources.list → deb
http ://scenari-platform.org/deb distrib-ubuntu
main → sudo apt update → sudo apt install
scenarichain4.2.fr-fr

♣ Depuis l’interface graphique ScenariChain

♥ Bouton Installer → Installer un pack → Installer
modèle Opale → Installer extension Basar →
Fermer fenêtre

♥ Bouton Ajouter → Créer un atelier → Code de
l’atelier → Cocher modèle Opale → Cocher
extension Basar → Créer

wsppacks & ateliers

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride

www.scenari.org
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Règles de remplissage des champs

♣ Panneau latéral gauche

(Clic droit : créer espaces et item, importer
ressources et exporter archives)

♣ Champ ouvert / Champ plié

(Clic gauche à 3 cm et double clic gauche sur barre
de titre)

♣ Palette d’enrichissement

(Mettre en forme dans un champ ouvert : gras,
citations, liens hypertextes, listes, symboles
mathématiques, listing informatiques)

♣ Point rouge d’insertion / Point d’interrogation

(Inclure de nouvelles lignes dans la grille, faire des
choix exclusifs)

♣ Feuille jaune

(Clic droit : insérer dans la grille de nouveaux
items-Scenari ou importer des documents externes)

Métadonnées

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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Règles de remplissage des champs

♣ Panneau latéral gauche

(Clic droit : créer espaces et item, importer
ressources et exporter archives)

♣ Champ ouvert / Champ plié

(Clic gauche à 3 cm et double clic gauche sur barre
de titre)

♣ Palette d’enrichissement

(Mettre en forme dans un champ ouvert : gras,
citations, liens hypertextes, listes, symboles
mathématiques, listing informatiques)

♣ Point rouge d’insertion / Point d’interrogation

(Inclure de nouvelles lignes dans la grille, faire des
choix exclusifs)

♣ Feuille jaune

(Clic droit : insérer dans la grille de nouveaux
items-Scenari ou importer des documents externes)

Métadonnées

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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Règles de remplissage des champs

♣ Panneau latéral gauche

(Clic droit : créer espaces et item, importer
ressources et exporter archives)

♣ Champ ouvert / Champ plié

(Clic gauche à 3 cm et double clic gauche sur barre
de titre)

♣ Palette d’enrichissement

(Mettre en forme dans un champ ouvert : gras,
citations, liens hypertextes, listes, symboles
mathématiques, listing informatiques)

♣ Point rouge d’insertion / Point d’interrogation

(Inclure de nouvelles lignes dans la grille, faire des
choix exclusifs)

♣ Feuille jaune

(Clic droit : insérer dans la grille de nouveaux
items-Scenari ou importer des documents externes)

Métadonnées

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride



Préacquis et prise en mains de Moodle
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Règles de remplissage des champs

♣ Panneau latéral gauche

(Clic droit : créer espaces et item, importer
ressources et exporter archives)

♣ Champ ouvert / Champ plié

(Clic gauche à 3 cm et double clic gauche sur barre
de titre)

♣ Palette d’enrichissement

(Mettre en forme dans un champ ouvert : gras,
citations, liens hypertextes, listes, symboles
mathématiques, listing informatiques)

♣ Point rouge d’insertion / Point d’interrogation

(Inclure de nouvelles lignes dans la grille, faire des
choix exclusifs)

♣ Feuille jaune

(Clic droit : insérer dans la grille de nouveaux
items-Scenari ou importer des documents externes)

Métadonnées

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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Règles de remplissage des champs

♣ Panneau latéral gauche

(Clic droit : créer espaces et item, importer
ressources et exporter archives)

♣ Champ ouvert / Champ plié

(Clic gauche à 3 cm et double clic gauche sur barre
de titre)

♣ Palette d’enrichissement

(Mettre en forme dans un champ ouvert : gras,
citations, liens hypertextes, listes, symboles
mathématiques, listing informatiques)

♣ Point rouge d’insertion / Point d’interrogation

(Inclure de nouvelles lignes dans la grille, faire des
choix exclusifs)

♣ Feuille jaune

(Clic droit : insérer dans la grille de nouveaux
items-Scenari ou importer des documents externes)

Métadonnées

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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Spectre d’activités

♣ Utiliser les points d’insertion de même niveau
vertical

(organiser le formulaire en groupes d’activités
d’apprentissage)

♣ Double clic sur la barre de titre des lignes d’activités

(plier, déplier et distinguer les activités de même
niveau vertical)

♣ Item Entrée d’activités

(décrire un ensemble d’activités non répertoriées)

♣ Champs apprenants/médiateurs à renseigner

(métadonnées, modalités, consignes, matériel, aires
d’apprentissage, compléments d’information)

Grille d’écriture

Bloc de champs

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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@Appr : Structuration du formulaire Basar 103

Spectre d’activités

♣ Utiliser les points d’insertion de même niveau
vertical

(organiser le formulaire en groupes d’activités
d’apprentissage)

♣ Double clic sur la barre de titre des lignes d’activités

(plier, déplier et distinguer les activités de même
niveau vertical)

♣ Item Entrée d’activités

(décrire un ensemble d’activités non répertoriées)

♣ Champs apprenants/médiateurs à renseigner

(métadonnées, modalités, consignes, matériel, aires
d’apprentissage, compléments d’information)

Grille d’écriture

Bloc de champs

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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Spectre d’activités

♣ Utiliser les points d’insertion de même niveau
vertical

(organiser le formulaire en groupes d’activités
d’apprentissage)

♣ Double clic sur la barre de titre des lignes d’activités

(plier, déplier et distinguer les activités de même
niveau vertical)

♣ Item Entrée d’activités

(décrire un ensemble d’activités non répertoriées)

♣ Champs apprenants/médiateurs à renseigner

(métadonnées, modalités, consignes, matériel, aires
d’apprentissage, compléments d’information)

Grille d’écriture

Bloc de champs

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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@Appr : Structuration du formulaire Basar 105

Spectre d’activités

♣ Utiliser les points d’insertion de même niveau
vertical

(organiser le formulaire en groupes d’activités
d’apprentissage)

♣ Double clic sur la barre de titre des lignes d’activités

(plier, déplier et distinguer les activités de même
niveau vertical)

♣ Item Entrée d’activités

(décrire un ensemble d’activités non répertoriées)

♣ Champs apprenants/médiateurs à renseigner

(métadonnées, modalités, consignes, matériel, aires
d’apprentissage, compléments d’information)

Grille d’écriture

Bloc de champs
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Formats de publication

♣ Format Web

(à intégrer comme un site Web embarqué)

♣ Format odt

(à convertir en .pdf pour une impression papier)

♣ Format IMSCC/SCORM

(à intégrer dans une plate-forme LCMS, grâce à un
plugin dédié)

Installation du plugin dans Moodle

♣ Télécharger le plugin IMS-CC Moodle sur
www.scenari.org

(choisir en fonction de la version de Moodle
installée)

Multi-supports

H. Quadjovie (mquadjovie@univ-lome.tg) Faire classe hybride
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Formats de publication

♣ Format Web

(à intégrer comme un site Web embarqué)

♣ Format odt

(à convertir en .pdf pour une impression papier)

♣ Format IMSCC/SCORM

(à intégrer dans une plate-forme LCMS, grâce à un
plugin dédié)

Installation du plugin dans Moodle

♣ Télécharger le plugin IMS-CC Moodle sur
www.scenari.org

(choisir en fonction de la version de Moodle
installée)

Multi-supports
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Médiatisation des aires d’apprentissage

Médiation tutorée d’apprentissage
Conducteur pédagogique
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Formats de publication

♣ Format Web

(à intégrer comme un site Web embarqué)

♣ Format odt

(à convertir en .pdf pour une impression papier)

♣ Format IMSCC/SCORM

(à intégrer dans une plate-forme LCMS, grâce à un
plugin dédié)

Installation du plugin dans Moodle

♣ Télécharger le plugin IMS-CC Moodle sur
www.scenari.org

(choisir en fonction de la version de Moodle
installée)

Multi-supports
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Formats de publication

♣ Format Web

(à intégrer comme un site Web embarqué)

♣ Format odt

(à convertir en .pdf pour une impression papier)

♣ Format IMSCC/SCORM

(à intégrer dans une plate-forme LCMS, grâce à un
plugin dédié)

Installation du plugin dans Moodle

♣ Télécharger le plugin IMS-CC Moodle sur
www.scenari.org

(choisir en fonction de la version de Moodle
installée)

Multi-supports
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Options de relecture

♣ Bouton Générer

(produire et générer le document final)

♣ Bouton Consulter

(ouvrir la publication depuis un lecteur dédié)

♣ Bouton Télécharger

(sauvegarder la production compressée)

♣ Bouton un Révéler

(ouvrir l’emplacement du document généré)

Importer l’export IMS-CC dans Moodle

♣ Télécharger le plugin IMS-CC Moodle

(Administration du site → Plugin )

Entête Web

Activité Web
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Options de relecture

♣ Bouton Générer

(produire et générer le document final)

♣ Bouton Consulter

(ouvrir la publication depuis un lecteur dédié)

♣ Bouton Télécharger

(sauvegarder la production compressée)

♣ Bouton un Révéler

(ouvrir l’emplacement du document généré)

Importer l’export IMS-CC dans Moodle

♣ Télécharger le plugin IMS-CC Moodle

(Administration du site → Plugin )

Entête Web

Activité Web
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Options de relecture

♣ Bouton Générer

(produire et générer le document final)

♣ Bouton Consulter

(ouvrir la publication depuis un lecteur dédié)

♣ Bouton Télécharger

(sauvegarder la production compressée)

♣ Bouton un Révéler

(ouvrir l’emplacement du document généré)

Importer l’export IMS-CC dans Moodle

♣ Télécharger le plugin IMS-CC Moodle

(Administration du site → Plugin )

Entête Web

Activité Web
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Préacquis et prise en mains de Moodle
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Options de relecture

♣ Bouton Générer

(produire et générer le document final)

♣ Bouton Consulter

(ouvrir la publication depuis un lecteur dédié)

♣ Bouton Télécharger

(sauvegarder la production compressée)

♣ Bouton un Révéler

(ouvrir l’emplacement du document généré)

Importer l’export IMS-CC dans Moodle

♣ Télécharger le plugin IMS-CC Moodle

(Administration du site → Plugin )

Entête Web

Activité Web
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Options de relecture

♣ Bouton Générer

(produire et générer le document final)

♣ Bouton Consulter

(ouvrir la publication depuis un lecteur dédié)

♣ Bouton Télécharger

(sauvegarder la production compressée)

♣ Bouton un Révéler

(ouvrir l’emplacement du document généré)

Importer l’export IMS-CC dans Moodle

♣ Télécharger le plugin IMS-CC Moodle

(Administration du site → Plugin )

Entête Web

Activité Web
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Schéma standard
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